Densify Connector Versions

Densify Connector Versions

#380510

Densify Connector Version Compatibility

Prior to installing or upgrading the PowerCLI version for your Densify Connector, please check the following compatibility list. Running incompatible versions may result in Action Automation failing to execute. Also see vCenter and PowerCLI Version Compatibility for a matrix of which versions are supported with each version of vCenter.

In general you want the latest version of the Densify Connector that meets your requirements.

Table: Densify Connector and PowerCLI and Version Compatibility List

Connector
Version

Certified
PowerCLI
Version

vCenter
Version

Comments

2.2.4.6

11.x, 12.x

7.0, 6.7.0,
6.7 U1, U3,
6.5 U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

If you are installing the Densify Connector for the first time, use this version.

2.2.4.5

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

2.2.4.4

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

2.2.4.3

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

Updated with the Apache Log4j 2.17.1 jar files to address security vulnerability CVE-2021-45046 and CVE-2021-45105, after the issue was initially reported in CVE-2021-44228.

The VMware audit has been updated to discontinue collection of data that is not used by any analyses. This update will reduce data load times and improve data collection performance.

2.2.4.2

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

If you are using v2.2.4.1 or v2.2.4.2 of the Densify Connector you must manually update your installation with the Apache Log4j 2.17.1 jar files to address the security vulnerability CVE-2021-45046 and CVE-2021-45105, after the issue was initially reported in CVE-2021-44228. See Updating the Apache Log4j Files.

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

This connector version uses TLS 1.2. This is the minimum supported version to secure the connection. If you are using TLS 1.1 or 1.0, this version of the connector will fail to authenticate. You must update your deployed TLS version.

2.2.4.1

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

If you are using v2.2.4.1 or v2.2.4.2 of the Densify Connector you must manually update your installation with the Apache Log4j 2.17.1 jar files to address the security vulnerability CVE-2021-45046 and CVE-2021-45105, after the issue was initially reported in CVE-2021-44228. See Updating the Apache Log4j Files.

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.4 with token-based authentication enabled by default.
  • Java v11*

*AdoptOpenJDK JRE 11.0.10 (jdk11.0.10_9) is installed automatically with the Densify Connector.

This connector version uses TLS 1.2. This is the minimum supported version to secure the connection. If you are using TLS 1.1 or 1.0, this version of the connector will fail to authenticate. You must update your deployed TLS version.

2.2.4

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.2;
  • Token-based authentication for vROps (enable by default in vROps v8.2.
  • OpenJDK 11.0.4 (jdk11.0.4_11_minimal)

This connector version uses TLS 1.2. This is the minimum supported version to secure the connection. If you are using TLS 1.1 or 1.0, this version of the connector will fail to authenticate. You must update your deployed TLS version.

2.2.3

11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version has been updated to certify PowerCLI 11.5.0.

If you are using vROps 8.1 or 8.2 we recommned upgrading to Densify Connector v2.2.4, otherwise you must manually switch your servers to use basic authentication with this version of the connector. You can enable basic authentication for the API as outlined in Connector Prerequisites.

This version has been certified with Densify v12.0 CP1, v12.0.2, v12.1.x.

AdoptOpenJDK (64-bit) Java version jdk8u202-b08 is installed automatically with this version of the Densify Connector.

Note: When you are working with Densify Connector v2.2.3 and vSphere 7.0, you may see warnings in the action automation log file regarding the vSphere version; however automation will still run.