Densify Connector Compatibility

Densify Connector Compatibility

#380510

Densify Connector Version Compatibility

Prior to installing or upgrading the PowerCLI version for your Densify Connector, please check the following compatibility list. Running incompatible versions may result in Action Automation failing to execute. Also see vCenter and PowerCLI Version Compatibility for a matrix of which versions are supported with each version of vCenter.

In general you want the latest version of the Densify Connector that meets your requirements.

Note: When you are working with vSphere 7.0, you may see warnings in action automation log file regarding the vSphere version; however automation will still run.

Table: Densify Connector and PowerCLI and Version Compatibility List

Connector
Version

Certified
PowerCLI
Version

vCenter
Version

Comments

2.2.4

10.x, 11.x, 12.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the Densify Connector is certified with:

  • PowerCLI 12.1;
  • vROps version 8.2;
  • Java v11*
  • Token-based authentication for vROps.

If you are installing the Densify Connector for the first time, use this version.

Densify Connector version 2.2.4 uses TLS 1.2. This is the minimum supported version to secure the connection. If you are using TLS 1.1 or 1.0, this version of the connector will fail to authenticate. You must update your deployed TLS version.

*OpenJDK 11.0.4 (jdk11.0.4_11_minimal) is installed automatically with the Densify Connector.

2.2.3

10.x, 11.x

7.0, 6.7.0, 6.7 U1
6.5.0, U1, U2

This version has been updated to certify PowerCLI 11.5.0.

If you are using vROps 8.1 or 8.2 we recommned upgrading to Densify Connector v2.2.4, otherwise you must manually switch your servers to use basic authentication with this version of the connector. You can enable basic authentication for the API as outlined in Connector Prerequisites.

This version provides the same certified feature set as Densify Connector v2.2.2 and has been certified with Densify v12.0 CP1, v12.0.2, v12.1.x.

AdoptOpenJDK (64-bit) Java version jdk8u202-b08 is installed automatically with this version of the Densify Connector.

2.2.2

10.x, 11.x

6.7.0, 6.7 U1
6.5.0, U1, U2

This version has been updated to address security issues with the Windows installer.

This version provides the same certified feature set as version 2.2.1, with the following exception: PowerCLI v11.4.0 has been certified on the Densify Connector v2.2.2.

AdoptOpenJDK (64-bit) Java version jdk8u202-b08 is installed automatically with this version of the Densify Connector.

This version of the connector has been certified with Densify v12.0.1, v12.0.2 and v12.1.0.

2.2.1

10.x, 11.x

6.7.0, 6.7 U1
6.5.0, U1, U2

This version supports token-based authentication (from vCenter Server), PowerCLI v11 and is only supported by Densify v11.0.10 and on-premise v12.0 or higher.

AdoptOpenJDK (64-bit) Java jdk8u202-b08 is installed automatically with this version of the Densify Connector. If this is an upgrade then this installation replaces the previous version of Oracle Java 1.8.0_76.

This version has been certified with Densify v12.0 and supports v12.0 CP1.

2.2.0

10.x, 11.x

6.7.0, 6.7 U1
6.5.0, U1, U2

This SaaS version supports token-based authentication (from vCenter Server), PowerCLI v11 and is only supported by Densify v11.0.10 or higher.

AdoptOpenJDK (64-bit) Java jdk8u202-b08 is installed automatically with this version of the Densify Connector. If this is an upgrade then this installation replaces the previous version of Oracle Java 1.8.0_76.

2.1.9

10.x

6.7.0
6.5.0, U1, U2

This SaaS version supports token-based authentication and is only supported by Densify v11.0.6 - v12.0.2.

This version is not supported by Densify v12.1 or higher.

If you are not using token-based authentication then you can remain at version 2.1.8.x.

2.1.8.2

10.x, 11.x

6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the connector is available for on-premise Densify v10.3 only.

It does not support token-based authentication.

You must install 10.3 CP8 in conjunction with this version of the Connector to address the issue of missing workloads in vROps 6.7 and 7.0. In these versions of vROps, the Memory Ballooning metric has been replaced by Memory Contention and the Active Memory metric has been replaced by Needed Memory.

2.1.8.1

10.x, 11.x

6.7.0, 6.7 U1
6.5.0, U1, U2

This version of the connector supports on-premise Densify v10.3 and does not support token-based authentication.

2.1.8

10.x

6.7.0
6.5.0, U1, U2

This version supports on-premise Densify v10.3 and does not support token-based authentication.